Enform Petroleum Safety

Enform Petroleum Safety

Number of people to train Price/person  
1-10 $154.95  
11-25 $139.95  
26-50 $129.95  
51-100 $124.95  
101-500 $119.95  
Price : $154.95

Petroleum Safety Training (PST) is an introductory online course for all employees - as an introduction for new hires to the petroleum industry or as a refresher for experienced workers, supervisors and managers. The course provides a general introduction and overview of health and safety hazards and how to control them. It discusses the legal framework that employers must follow and focuses on workers' and employers' responsibilities with respect to health and safety at work.

PST is an interactive multi-media course with video, audio, and interactive lessons.

Topics Include:

  • Petroleum industry processes overview
  • Rights and responsibilities
  • Hazard recognition, assessment and control
  • Personal Protective Equipment and clothing
  • Education, training and competency
  • Safety communication
  • Emergency Response Planning and incident reporting
  • Special topics in the petroleum industry

 

Outcomes:

Each topic is follow by a short skills test. Once the course is completed, a completion status report can be printed indicating that you have completed the course. Certificates of Completion for this course do not expire.

 

Additional Notes:

  • Testing and Certification: Each topic is followed by a short skills test to ensure learner comprehension. Once the program is completed, a Completion Report can be printed indicating that you have completed the program and Enform will mail out a permanent certification card to the address we have on record.
  • Expiry Policy Change: Effective July 1, 2009 PST certificates no longer expire. This policy change pertains to certificates with or without printed dates of expiry. There is no Enform requirement to retake the PST if current certificate carries an expiry date.
  • This program is compatible with: Windows XP SP3 or higher; Windows Vista (32 bit and 64 bit), Windows 7 (32 bit and 64 bit), and Mac OS 10.6 or higher.
  • PST 2.0 is compatible with: Internet Explorer 7, Safari 5, Firefox 4, or newer.
  • Flasher Player 9 or higher is required

DISCLAIMER-Any user of the online courses provided by Alert First-Aid Inc. found on the website www.alertfirstaid.com acknowledges and agrees that Alert First-Aid Inc. (the “Company”) disclaims all liability and legal responsibility howsoever caused for the information contained in or referenced in any of the online courses. The Company does not warrant that the information will be sufficient for the user’s purposes and takes no responsibility for the consequences of how the information is used by the user or any employee or affiliate of the user.